package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s([A-Z_]+\.)([A-Za-z0-9_]+)`)
var str = `SELECT HOSP.TIPO, HOSP.FECHA_INGRESO, HOSP.FECHA_ALTA, HOSP.NHC, HOSP.EPISODIO, HOSP.ID, HOSP.SEXO, HOSP.FNAC, HOSP.MEDICO, HOSP.MUTUA, HOSP.MOTIVO, HOSP.DIAG, HOSP.PROC, HOSP.MES_ALTA, HOSP.ESPECIALIDAD, HOSP.ESTADO
FROM HOSP;
`
var substitution = " MAX(Len(\1\2)) AS \2"
fmt.Println(re.ReplaceAllString(str, substitution))
}