re = /\s([A-Z_]+\.)([A-Za-z0-9_]+)/
str = 'SELECT HOSP.TIPO, HOSP.FECHA_INGRESO, HOSP.FECHA_ALTA, HOSP.NHC, HOSP.EPISODIO, HOSP.ID, HOSP.SEXO, HOSP.FNAC, HOSP.MEDICO, HOSP.MUTUA, HOSP.MOTIVO, HOSP.DIAG, HOSP.PROC, HOSP.MES_ALTA, HOSP.ESPECIALIDAD, HOSP.ESTADO
FROM HOSP;
'
subst = ' MAX(Len(\\1\\2)) AS \\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result