#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\([^)]*\))"
Local $sString = "'this is my string (anything within brackets)'"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)