$re = '/(\([^)]*\))/';
$str = '\'this is my string (anything within brackets)\'';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;