const regex = /(?<=Current Balance:\s*)\S+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Current Balance:\\s*)\\S+', 'gm')
const str = `Current Balance: INR2,137,381.99 8/9/2020 Impaired normal`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}