$re = '/(?<=Current Balance:\s*)\S+/m';
$str = 'Current Balance: INR2,137,381.99 8/9/2020 Impaired normal';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);