re = /(?<=Current Balance:\s*)\S+/m
str = 'Current Balance: INR2,137,381.99 8/9/2020 Impaired normal'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end