package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)src\s*="(.+?)"`)
var str = `<img src="/images/image.jpg"><img src="/images/defimage1.jpg">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}