re = /src\s*="(.+?)"/m
str = '<img src="/images/image.jpg"><img src="/images/defimage1.jpg">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end