$re = '/src\s*="(.+?)"/m';
$str = '<img src="/images/image.jpg"><img src="/images/defimage1.jpg">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);