const regex = new RegExp('(?=[A-Z][a-z])', 'gm')
const str = `ABCowDog`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);