$re = '/(?=[A-Z][a-z])/m';
$str = 'ABCowDog';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;