use strict;
my $str = 'ABCowDog';
my $regex = qr/(?=[A-Z][a-z])/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";