#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)^(.*?)((\d[a-z]?\.?)+-.*)$"
Local $sString = "xorg-fonts-misc-1.0b-1" & @CRLF & _
"Xorg-font-bitstream-75dpi-1.0.0-2.i386" & @CRLF & _
"Xorg-font-bitstream-100dpi-1.2a-2.arm" & @CRLF & _
"Other-Third-Party-1.2.2-1-any"
Local $sSubst = "\1 \2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)