use strict;
my $str = 'xorg-fonts-misc-1.0b-1
Xorg-font-bitstream-75dpi-1.0.0-2.i386
Xorg-font-bitstream-100dpi-1.2a-2.arm
Other-Third-Party-1.2.2-1-any';
my $regex = qr/^(.*?)((\d[a-z]?\.?)+-.*)$/mip;
my $subst = '\\1 \\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";