import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)((\\d[a-z]?\\.?)+-.*)$";
final String string = "xorg-fonts-misc-1.0b-1\n"
+ "Xorg-font-bitstream-75dpi-1.0.0-2.i386\n"
+ "Xorg-font-bitstream-100dpi-1.2a-2.arm\n"
+ "Other-Third-Party-1.2.2-1-any";
final String subst = "\\1 \\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}