using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"var informations ?= ?{(?=.*""titre"" ?: ?(?:(?:""(?:[^""]|\\"")*[^\\]"")|(?:'(?:[^']|\\')*[^\\]')))(?=.*""typeTableaux"" ?: ?\[ ?(?:(?:(?:""(?:[^""]|\\"")*[^\\]"")|(?:'(?:[^']|\\')*[^\\]'))(?:(?: ?, ?(?=[""']))|(?: ?))){3} ?\])(?=.*""genreTableaux"" ?: ?([""'])[mf]\1)(?=.*""typeElements"" ?: ?\[ ?(?:(?:(?:""(?:[^""]|\\"")*[^\\]"")|(?:'(?:[^']|\\')*[^\\]'))(?:(?: ?, ?(?=[""']))|(?: ?))){2} ?\])(?=.*""genreElements"" ?: ?([""'])[mf]\2)";
string input = @"var informations = { ""titre"": '6 albums de sonates de D. Scarlatti numérotées selon le catalogue <abbr title=""Kirkpatrick"">Kk</abbr>', ""typeTableaux"": [""album"", ""albums"", ""album(s)""], ""genreTableaux"": ""m"", ""typeElements"": [""piste"", ""pistes""], ""genreElements"": ""f""}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}