$re = '/var informations ?= ?{(?=.*"titre" ?: ?(?:(?:"(?:[^"]|\\\\")*[^\\\\]")|(?:\'(?:[^\']|\\\\\')*[^\\\\]\')))(?=.*"typeTableaux" ?: ?\[ ?(?:(?:(?:"(?:[^"]|\\\\")*[^\\\\]")|(?:\'(?:[^\']|\\\\\')*[^\\\\]\'))(?:(?: ?, ?(?=["\']))|(?: ?))){3} ?\])(?=.*"genreTableaux" ?: ?(["\'])[mf]\1)(?=.*"typeElements" ?: ?\[ ?(?:(?:(?:"(?:[^"]|\\\\")*[^\\\\]")|(?:\'(?:[^\']|\\\\\')*[^\\\\]\'))(?:(?: ?, ?(?=["\']))|(?: ?))){2} ?\])(?=.*"genreElements" ?: ?(["\'])[mf]\2)/';
$str = 'var informations = { "titre": \'6 albums de sonates de D. Scarlatti numérotées selon le catalogue <abbr title="Kirkpatrick">Kk</abbr>\', "typeTableaux": ["album", "albums", "album(s)"], "genreTableaux": "m", "typeElements": ["piste", "pistes"], "genreElements": "f"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);