using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^|\s)T\d+(?=\s|$)";
string input = @"this is T1 - match T34j
this is @T1 - not a match T345
T1 - match";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}