$re = '/(?<=^|\s)T\d+(?=\s|$)/';
$str = 'this is T1 - match T34j
this is @T1 - not a match T345
T1 - match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);