const regex = /(?<=^|\s)T\d+(?=\s|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^|\\s)T\\d+(?=\\s|$)', 'g')
const str = `this is T1 - match T34j
this is @T1 - not a match T345
T1 - match`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}