import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(.*?)\\]\\((\\S*?) ?('(.*?)')?\\)";
final String string = "[Descriptive text](https://example.com/ 'Title text')\n\n"
+ "[Descriptive text\n"
+ "Accepts linkebreak](https://example.com/ 'Title text\n"
+ "Accepts linkebreaks')";
final String subst = "<a href=\"$2\" title=\"$4\">$1</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}