re = /\[(.*?)\]\((\S*?) ?('(.*?)')?\)/
str = '[Descriptive text](https://example.com/ \'Title text\')
[Descriptive text
Accepts linkebreak](https://example.com/ \'Title text
Accepts linkebreaks\')'
subst = '<a href="$2" title="$4">$1</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result