const regex = /\[(.*?)\]\((\S*?) ?('(.*?)')?\)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(.*?)\\]\\((\\S*?) ?(\'(.*?)\')?\\)', 'gs')
const str = `[Descriptive text](https://example.com/ 'Title text')
[Descriptive text
Accepts linkebreak](https://example.com/ 'Title text
Accepts linkebreaks')`;
const subst = `<a href="$2" title="$4">$1</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);