# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([A-Z]+).*$/$1/gm;t' <<< "A1
A1:D10
AD10
AD1:BBB1"