$re = '~^([A-Z]+).*$~m';
$str = 'A1
A1:D10
AD10
AD1:BBB1';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;