const regex = new RegExp('^([A-Z]+).*$', 'gm')
const str = `A1
A1:D10
AD10
AD1:BBB1`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);