package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((--foo ))([(((--)\w+)( \w+))]+)( --number )\d+$`)
var str = `--foo --bar baz --zac big --number 1`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}