$re = '/^((--foo ))([(((--)\w+)( \w+))]+)( --number )\d+$/';
$str = '--foo --bar baz --zac big --number 1';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);