using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\d+|(?<!>|<|=)\s+\d+)";
string input = @"128 and 228 and alpha > 200 and bravo < 400 or charlie = 400";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}