re = /(^\d+|(?<!>|<|=)\s+\d+)/
str = '128 and 228 and alpha > 200 and bravo < 400 or charlie = 400'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end