$re = '/(^\d+|(?<!>|<|=)\s+\d+)/';
$str = '128 and 228 and alpha > 200 and bravo < 400 or charlie = 400';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);