package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{E=([^,]*),Q=([^}]*)}`)
var str = `[{E=KT,Q=P1.p01},{E=KT2,Q=P2.p02}]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}