// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"{E=([^,]*),Q=([^}]*)}").unwrap();
let string = "[{E=KT,Q=P1.p01},{E=KT2,Q=P2.p02}]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}