$re = '/{E=([^,]*),Q=([^}]*)}/';
$str = '[{E=KT,Q=P1.p01},{E=KT2,Q=P2.p02}]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);