using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bFoo Bar\b|(\bBar\b)";
string input = @"lore ipsum Bar lore ipsum
lorem ipsuem Foo Bar lorem ipsuem";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}