$re = '/\bFoo Bar\b|(\bBar\b)/';
$str = 'lore ipsum Bar lore ipsum
lorem ipsuem Foo Bar lorem ipsuem';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);