re = /\bFoo Bar\b|(\bBar\b)/
str = 'lore ipsum Bar lore ipsum
lorem ipsuem Foo Bar lorem ipsuem'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end