# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ *\d+\. *//gm;t' <<< "1. ddgfhgf
a. asdf
b. sdaf
c. sadf
d. dsaf
546.asdf
a) hoihoij
b) dsfdsfa
c) fdghfgh
d) sdfggfhs
2.asffa
a) hoihoij
b) dsfdsfa
c) fdghfgh
d) sdfggfhs
789.adf
a) hoihoij
b) dsfdsfa
c) fdghfgh
d) sdfggfhs
3.adgag
a) hoihoij
b) dsfdsfa
c) fdghfgh
d) sdfggfhs"