$re = '/ *\d+\. */m';
$str = '1. ddgfhgf
a. asdf
b. sdaf
c. sadf
d. dsaf
546.asdf
a) hoihoij
b) dsfdsfa
c) fdghfgh
d) sdfggfhs
2.asffa
a) hoihoij
b) dsfdsfa
c) fdghfgh
d) sdfggfhs
789.adf
a) hoihoij
b) dsfdsfa
c) fdghfgh
d) sdfggfhs
3.adgag
a) hoihoij
b) dsfdsfa
c) fdghfgh
d) sdfggfhs';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;