import Foundation
let pattern = #" *\d+\. *"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1. ddgfhgf
a. asdf
b. sdaf
c. sadf
d. dsaf
546.asdf
a) hoihoij
b) dsfdsfa
c) fdghfgh
d) sdfggfhs
2.asffa
a) hoihoij
b) dsfdsfa
c) fdghfgh
d) sdfggfhs
789.adf
a) hoihoij
b) dsfdsfa
c) fdghfgh
d) sdfggfhs
3.adgag
a) hoihoij
b) dsfdsfa
c) fdghfgh
d) sdfggfhs
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)