package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[[^\[]*\]`)
var str = `Test[Test1][Test2]Test3
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}