$re = '/\[[^\[]*\]/m';
$str = 'Test[Test1][Test2]Test3
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;