use strict;
my $str = 'Test[Test1][Test2]Test3
';
my $regex = qr/\[[^\[]*\]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";