$re = '/^[0-9 A-Z]*[A-Z][0-9 A-Z]*[0-9][0-9 A-Z]*$/m';
$str = '3 T1F ROHITE01WMILWI16
3 T1F ROHITHE01WMILwI16
3 T1F ROHITHE01WMIL.I16
1234
aaaa
T1F ROHITHE01WMILWI16';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);