// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9 A-Z]*[A-Z][0-9 A-Z]*[0-9][0-9 A-Z]*$").unwrap();
let string = "3 T1F ROHITE01WMILWI16
3 T1F ROHITHE01WMILwI16
3 T1F ROHITHE01WMIL.I16
1234
aaaa
T1F ROHITHE01WMILWI16";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}