import Foundation
let pattern = #"^[0-9 A-Z]*[A-Z][0-9 A-Z]*[0-9][0-9 A-Z]*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
3 T1F ROHITE01WMILWI16
3 T1F ROHITHE01WMILwI16
3 T1F ROHITHE01WMIL.I16
1234
aaaa
T1F ROHITHE01WMILWI16
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)