$re = '/[pP]iece[_]*?[iI]*[dD]* ?[=]* ?"?(?<PieceID>[A-Z0-9]{16})"?/m';
$str = 'piece_id="E00401007758725D"
PieceID = E00401007758725D
Piece=E00401007758725D
piece E00401007758725D';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);