import re
regex = re.compile(r"[pP]iece[_]*?[iI]*[dD]* ?[=]* ?\"?(?<PieceID>[A-Z0-9]{16})\"?", flags=re.MULTILINE)
test_str = ("piece_id=\"E00401007758725D\"\n"
"PieceID = E00401007758725D \n"
"Piece=E00401007758725D\n"
"piece E00401007758725D")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")