re = /[pP]iece[_]*?[iI]*[dD]* ?[=]* ?"?(?<PieceID>[A-Z0-9]{16})"?/m
str = 'piece_id="E00401007758725D"
PieceID = E00401007758725D
Piece=E00401007758725D
piece E00401007758725D'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end